Welcome to eko web blog

terkadang kita direpotkan oleh IP Speedy yang berubah ubah terus dari hari ke hari. kalo mau diremote dari arah publik kan repot nyari ip publicnya si modem atau router. solusinya bisa menggunakan mikrotik dan web no-ip.com

kita lihat topologi berikut:

topologi dynamic ip

Laptop tidak dapat mengakses router mikrotik jika kita tidak mengetahui ip public-nya.

ada beberapa hal yang akan saya jelaskan disini:

1. Laptop Berada di kota Palembang

2. Mikrotik berada di kota jakarta.

3. laptop akan mengakses mikrotik memerlukan IP Public.

4. koneksi yang digunakan adalah telkom speedy (ip public-nya berubah-ubah terus atau dynamic ip public)

5. modem adsl biasanya TP-link (Di-set sebagai Bridge) artinya proses dial-up bukan langsung dari modem melainkan dari mikrotik. nantinya IP Public akan terpasang pada Mikrotik (BUKAN MODEM ADSL TP-LINK).

LANGKAH KERJA:

A. PEMBUATAN DOMAIN PENGGANTI IP PUBLIC

1. buka halaman web http://www.noip.com/ ikuti proses pendaftaran akun-nya.

(Saya anggap anda berhasil registrasi account)

2. silakan login terlebih dahulu.

3. klik tombol host/redirect klik tombol add host

noipcom

masukkan nama domain anda misal ekomuba lalu pilih nama domain induknya misal sytes.net

maka nanti alamat pengganti ip public router mikrotik anda adalah ekomuba.sytes.net bukan menggunakan ip public lagi.

 

jika telah selesai, maka klik tombol add host pada bagian bawah

pada step ini proses pendaftaran nama domain telah sukses. sekarang kita masuk konfigurasi pada mikrotik.

 

B. PENGATURAN MIKROTIK.

1. buat scripts baru dengan nama  no-ip_ddns_update

system – script. tekan tombol +

mikrotik noip

pastekan source code nya dibawah ini:

# No-IP automatic Dynamic DNS update

#————— Change Values in this section to match your setup ——————

# No-IP User account info
:local noipuser “emailanda@yahoo.co.id
:local noippass “password-anda

# Set the hostname or label of network to be updated.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas.
:local noiphost “namadomain-anda.sytes.net

# Change to the name of interface that gets the dynamic IP address
:local inetinterface “pppoe-user-speedy

#————————————————————————————
# No more changes need

:global previousIP

:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP on the interface
:local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]

# Strip the net mask off the IP address
:for i from=( [:len $currentIP] – 1) to=0 do={
:if ( [:pick $currentIP $i] = “/”) do={
:set currentIP [:pick $currentIP 0 $i]
}
}

:if ($currentIP != $previousIP) do={
:log info “No-IP: Current IP $currentIP is not equal to previous IP, update needed”
:set previousIP $currentIP

# The update URL. Note the “\3F” is hex for question mark (?). Required since ? is a special character in commands.
:local url “http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP”
:local noiphostarray
:set noiphostarray [:toarray $noiphost]
:foreach host in=$noiphostarray do={
:log info “No-IP: Sending update for $host”
/tool fetch url=($url . “&hostname=$host”) user=$noipuser password=$noippass mode=http dst-path=(“no-ip_ddns_update-” . $host . “.txt”)
:log info “No-IP: Host $host updated on No-IP with IP $currentIP”
}
} else={
:log info “No-IP: Previous IP $previousIP is equal to current IP, no update needed”
}
} else={
:log info “No-IP: $inetinterface is not currently running, so therefore will not update.”
}

atau klik ini source no-ip

 

2. buat scheduler baru lalu jalankan script ini setiap  5 menit atau brp menit terserah anda.

/system scheduler add comment="Update No-IP DDNS" disabled=no interval=5m \
name=no-ip_ddns_update on-event=no-ip_ddns_update policy=read,write,test

pekerjaan selesai.


silakan ping dari laptop (palembang) lalu ping domainanda.sytes.net maka akan muncul ip public speedy router mikrotik di kota jakarta. (Asumsi)


terimakasih.

Beberapa frekuensi standar LNB..

LNB C Band
– Frekuensi LNB: 5150
– Jangkauan frekuensi, antara 3400 sampai 4200
– Kebanyakan satelit di Asia menggunakan frekuensi C Band, termasuk Palapa dan Telkom

LNB Ku Band
– Frekuensi LNB: 9750/10600 (frekuensi atas/frekuensi bawah)
– Jangkauan frekuensi, antara 10xxx sampai 12xxx
– Beberapa satelit di Asia menggunakan frekuensi Ku Band, seperti NSS 6, Measat 3, dll

LNB S Band
– Frekuensi LNB: 3620
– Jangkauan frekuensi, antara 2520 sampai 2670 (jangkauan frekuensi yg sekecil ini mungkin juga jadi penyebab tidak bisa dilocknya 1 frekuensi di Indovision, berdasarkan Lyngsat, yakni 2505 V 22500, karena sudah diluar jangkauan)
– Satu-satunya yang menggunakan frekuensi S Band untuk wilayah Asia, yakni SES 7, yang digunakan oleh pay TV Indovision

From: forsat

75’BT ABS 1 (12579 H 22000) Jangkauan: Sumatra bagian
utara dan tengah
siaran rohani

76,5’BT Apstar 7 (11167 v
45000)
Jangkauan: Aceh dan Sumut pay TV Skynet Myanmar

78,5’BT Thaicom 5(12272 v
30000)
Jangkauan: Sumatra,
Kalimantan , Jawa, Sulawesi
bagian utara dan tengah pay TV Truevision , dan
beberapa siaran unggulan yang
diacak Irdeto, tapi bisa dibuka
dengan key

88’BT ST 2
Jangkauan: seluruh Indonesia siaran Taiwan
91,5’BT Measat 3(10982 v 30000)
Jangkauan: seluruh Indonesia
(untuk Astro jangkauan sama
seperti Thaicom 5)
pay TV Astro dan Aora TV

95’BT NSS 6(11131 v 30000)
Jangkauan: hanpir seluruh
Indonesia (kecuali Indonesia
bagian timur)
pay TV IPM (biss), channel

Thailand 108,2’BT NSS 11(12411 v 11111)
Jangkauan: Sulawesi, Kaltim,
Malut
Zamjari , pay TV Cignal

110,5’BT Chinasat 10(12285 v
3800) Jangkauan: Indonesia
channel data

113’BT Koreasat 5(12470 v
25600)
Jangkauan: Sulawesi,
Kalimantan , bahkan sampai Lampung
pay TV Dream TV

113’BT Palapa D(12715 h 29900)
Jangkauan: seluruh Indonesia
pay TV Orange TV

122,2’BT Asiasat 4(12362 v 9404)
Jangkauan: Jawa, Bali sampai
NTT, Lampung, Kalbar, Sulsel
Sport 1 Russia (full match EPL,
FTA)

132’BT Vinasat 1(11090 v 28125)

Jangkauan: Sumatra bagian

utara, Kalimantan bagian barat
pay TV dari Vietnam, HTV 1-HTV
9

152’BT Optus D2(12407 v 30000) Jangkauan: Jawa, Papua, Bali
sampai NTT
channel Australia dan Eropa

156’BT Optus C1/D3(12407 h
12600)
Jangkauan: Jawa, Lampung, Papua, Bali sampai NTT
pay TV Foxtel, Adult Only

166’BT Intelsat 19(12726 h
28066)
Jangkauan: Lampung, Jawa, Bali

 

copast dari forsat :D thanks forsat and all member

baru baru ini dapat project mendesain VLAN antar tower yang digunakan untuk voip, line speedy dan LAN. berikut perintah dan topologi nya. Baca entri selengkapnya »

I. PENDAHULUAN

Artikel kali ini akan menjelaskan tentang pengunaan iptables lebih lanjut yaitu bagaimana cara membuat port forwarding dengan menggunakan iptables. Port forwarding merupakan sebuah konsep untuk meneruskan paket yang datang dari ip dan port tertentu ke ip dan port tertentu. Konsep ini mengijinkan seorang user untuk mengakses sebuah layanan seperti telnet atau ssh di jaringan lokal dari jaringan publik. Misalnya seseorang sedang menggunakan IP publik a.b.c.d ingin mengakses layanan ssh yang ada di jaringan lokal w.x.y.z. Maka dengan menggunakan port forwarding orang tersebut bisa melaksanakan hal tersebut. Kelemahan dari port forwarding adalah jika kita menggunakan sebuah port untuk forwarding maka port tersebut tidak dapat digunakan lagi. Port forwarding sering disebut juga PAT (Port Address Translation) atau NAPT (Network Address and Port Translation). Di artikel ini, penulis menggunakan Centos 5.4 sebagai distronya dan menggunakan iptables versi 1.3.5 dan seharusnya artikel ini dapat digunakan oleh berbagai macam distro dan berbagai versi iptables.

II. CARA KERJA

Port forwarding merupakan kebalikan dari proses masquerading (NAT). Jika pada proses NAT yang terjadi adalah beberapa komputer lokal LAN terhubung ke internet melalui IP Publik, maka pada port forwarding yang terjadi adalah koneksi dari internet masuk ke dalam komputer yang ada di dalam LAN kita. Untuk lebih memudahkan bagaimana port forwarding itu bekerja bayangkanlah seorang resepsionis kantor yang hanya mempunyai satu nomor publik untuk menghubungi nomor telepon luar. Jika misalnya ada orang dari luar menelpon ke kantor tersebut untuk berbicara dengan seseorang yang bernama badu misalnya, maka resepsionis akan menghubung badu melalui nomor ekstensi si badu itu sendiri. Tetapi dari si badu tidak bisa menelpon ke luar. Berdasarkan analogi tersebut, dapat dianalogikan bahwa telepon si resepsionis merupakan sebuah server yang mempunyai 2 ethernet yaitu IP publik dan IP lokal. Sedangkan ekstensi si badu merupakan nomor port sebuah layanan di sebuah server lokal. Jika seseorang ingin menggunakan layanan ke dalam sebuah server lokal, maka dia harus menuliskan port dari layanan tersebut.

III. LANGKAH-LANGKAH

Sebelum kita mengunakan Port forwarding, maka ada dua hal yang harus dikonfigurasi. Pertama adalah routing kernel. Routing kernel harus bernilai 1 agar port forwarding dapat berjalan. Ketikkan perintah berikut:

# vi /etc/sysctl.conf

Lalu cari pada file tersebut tulisan

net.ipv4.ip_forward

dan rubah nilainya menjadi 1, sehingga akan menjadi:

net.ipv4.ip_forward = 1

Yang kedua adalah file ip_forward. Ketikan perintah berikut:

# vi /proc/sys/net/ipv4/ip_forward

Ubah nilainya menjadi 1.

Setelah kedua hal tersebut dikonfigurasi, maka kita bersiap untuk melakukan port forwarding. Port forwarding mempunyai format seperti berikut:

iptables -t nat [-command] PREROUTING [-p protocol] –dport [port yang diinginkan] -d [IP publik] -j DNAT –to [ip_tujuan:port tujuan]

Setelah kita melakukan port forwarding, maka jangan lupa untuk melakukan hal berikut:

iptables -t nat -A POSTROUTING -o [ethernet lokal] -j MASQUERADE

Di bawah ini akan diberikan contoh-contoh agar kita dapat memahami implementasi port forwarding dengan lebih baik. Contoh-contoh ini berasumsi bahwa kita mempunyai 2 ethernet yaitu eth0 dengan IP 123.45.67.89 dan eth1 dengan IP lokal 192.168.0.2. Dan seluruh rantai semuanya berpolicy ACCEPT. Begitu juga dengan komputer lokal dengan IP 192.168.0.13 yang seluruh rantai iptables-nya berpolicy ACCEPT. Jika memang iptables kita mempunyai rantai yang berpolicy DROP, maka hanya tinggal membuka saja port-port tersebut.

1. Memforward web Server

Misalnya kita mempunyai sebuah aplikasi MRTG untuk melihat traffik jaringan di lokal kita. Kita ingin agar ketika pulang dari kantor kita bisa memantau kondisi jaringan kantor kita. Maka dari itu kita akan menggunakan konsep port forwarding ini untuk melaksanaakn maksud tersebut. Untuk melaksanakan hal tersebut kita akan membuka port 23456 dari server gateway kita. Tuliskan perintah-perintah berikut:

# iptables -t nat -A PREROUTING -p tcp –dport 23456 -d 123.45.67.89 -j DNAT –to-destination 192.168.0.2:80

# iptables -I INPUT -p tcp -d 123.45.67.89 –dport 80 -j DROP

# iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

Perintah iptables pertama memberikan perintah agar setiap protokol tcp yang menuju IP 123.45.67.89 dengan port 23456 akan diteruskan ke IP 192.168.0.2 dengan port 80. Perintah kedua memberikan perintah agar setiap protokol tcp yang menuju IP 123.45.67.89 dengan port 80 akan di drop. Sedangkan perintah terakhir memberikan perintah Masquerade untuk ethernet lokal dalam hal ini eth1. Sekarang cobalah ke browser dan ketikkan http://123.45.67.89:23456/mymrtg

Maka seharusnya kita sudah bisa melihat aplikasi MRTG kita dari IP publik. Bandingkan dengan kita hanya mengetikkan browser seperti berikut:

http://123.45.67.89/mymrtg

Maka akan terjadi error.

2. Memforward layanan telnet

Misalnya kita ingin melakukan telnet kepada sebuah server yang ada di dalam jaringan lokal kita dan kita berada di luar kantor serta menggunakan IP publik. Maka dari itu kita mengetikkan di iptables perintah sebagai berikut:

# iptables -t nat -A PREROUTING -p tcp –dport 12345 -d 123.45.67.89 -j DNAT –to-destination 192.168.0.13:23

# iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

Perintah iptables pertama memberikan perintah agar setiap protokol tcp yang menuju IP 123.45.67.89 dengan port 12345 akan diteruskan ke IP 192.168.0.13 dengan port 23. Sedangkan perintah terakhir memberikan perintah Masquerade untuk ethernet lokal dalam hal ini eth1. Untuk melakukan telnet, maka kita mengertikkan formatnya sebagai berikut:

# telnet [ip publik] [port layanan]

Dalam kasus ini, kita mengetikkan sebagai berikut:

# telnet 123.45.67.89 12345 Dan seharusnya kita akan masuk ke server dengan IP 192.168.0.13 melalui mode telnet.

3. Memforward layanan ssh Misalnya kita ingin melakukan ssh kepada sebuah server yang ada di dalam jaringan lokal kita dan kita berada di luar kantor serta menggunakan IP publik. Maka dari itu kita mengetikkan di iptables perintah sebagai berikut:

# iptables -t nat -A PREROUTING -p tcp –dport 34567 -d 123.45.67.89 -j DNAT –to-destination 192.168.0.13:22

# iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE Perintah iptables pertama memberikan perintah agar setiap protokol tcp yang menuju IP 123.45.67.89 dengan port 34567 akan diteruskan ke IP 192.168.0.13 dengan port 22. Sedangkan perintah terakhir memberikan perintah Masquerade untuk ethernet lokal dalam hal ini eth1. Untuk melakukan ssh, maka kita mengertikkan formatnya sebagai berikut:

# ssh nama_user@ip_publik -p [port layanan]

Dalam kasus ini, kita mengetikkan sebagai berikut:

# ssh arfie@123.45.67.89 -p 34567

Dan seharusnya kita akan masuk ke server dengan IP 192.168.0.13 melalui mode ssh. IV. CATATAN PENTING Perlu diketahui bahwa jika kita menggunakan sebuah port untuk port forwarding maka port tersebut tidak dapat dipakai lagi. Maka dari itu, sebelum kita menggunakan port, cek terlebih dahulu apakah port tersebut masih tersedia atau tidak. Dan sebaiknya jangan menggunakan port-port yang sudah familiar penggunaannya seperti port 22, port 23, dan sebagainya jika ingin digunakan untuk port forwarding karena dikhawatirkan kita belum mensetting ulang service-service yang menggunaka port-port tersebut sehingga akan terjadi bentrok. Dan juga untuk melihat port-port mana saja yang digunakan oleh linux, lihat saja di file /etc/services. Sebaiknya gunakan port di atas port 10000 jika ingin digunakan untuk port forwarding dan perlu diketahui bahwa batas port hanya sampai port 65563. Jadi masih banyak puluhan ribu port yang masih lowong untuk dipergunakan sebagai port forwarding.

REFERENSI:

https://forum.linux.or.id/

http://en.wikipedia.org/

http://www.simonzone.com/

http://www.kostumluar.co.cc/

http://forshare.info/

Cloud computing is a marketing term for technologies that provide computation, software, data access, and storage services that do not require end-user knowledge of the physical location and configuration of the system that delivers the services. A parallel to this concept can be drawn with the electricity grid, wherein end-users consume power without needing to understand the component devices or infrastructure required to provide the service.

Cloud computing describes a new supplement, consumption, and delivery model for IT services based on Internet protocols, and it typically involves provisioning of dynamically scalable and often virtualised resources.[1][2] It is a byproduct and consequence of the ease-of-access to remote computing sites provided by the Internet.[3] This may take the form of web-based tools or applications that users can access and use through a web browser as if the programs were installed locally on their own computers.[4]

Cloud computing providers deliver applications via the internet, which are accessed from web browsers and desktop and mobile apps, while the business software and data are stored on servers at a remote location. In some cases, legacy applications (line of business applications that until now have been prevalent in thin client Windows computing) are delivered via a screen-sharing technology, while the computing resources are consolidated at a remote data center location; in other cases, entire business applications have been coded using web-based technologies such as AJAX.

At the foundation of cloud computing is the broader concept of infrastructure convergence (or Converged Infrastructure) and shared services.[5]This type of data center environment allows enterprises to get their applications up and running faster, with easier manageability and less maintenance, and enables IT to more rapidly adjust IT resources (such as servers, storage, and networking) to meet fluctuating and unpredictable business demand.[6] [7]

Most cloud computing infrastructures consist of services delivered through shared data-centers and appearing as a single point of access for consumers’ computing needs. Commercial offerings may be required to meet service-level agreements (SLAs), but specific terms are less often negotiated by smaller companies.[8][9]

The tremendous impact of cloud computing on business has prompted the federal United States government to look to the cloud as a means to reorganize their IT infrastructure and decrease their spending budgets. With the advent of the top government official mandating cloud adoption, many agencies already have at least one or more cloud systems online. [10]

tulisan ini sengaja saya posting hanya ingin menyampaikan pandangan dari seorang yang biasa-biasa saja tidak bermaksud menyinggung pembaca sekalian. sewaktu waktu saya ingin membacanya ada dan perasaan ini pernah ada dalam hati saya atau hati para pembaca sekalian terlepas itu hal yang menggembirakan bagi anda atau hal yang bertentangan bagi anda.

setiap insan yang hidup pasti mempunyai suatu prinsip dalam hidupnya. suatu prinsip biasanya bersifat mutlak dan tidak bisa dikonfromikan atau ditukar dengan apapun karena jika kita mendapati sesuatu hal yang bertentangan dalam suatu hal maka otomatis ada perasaaan yang muncul dengan sendirinya yang disebut dengan “kecewa”. kesenjangan dari prinsip ini boleh kita artikan antara jauhnya harapan kita dari kenyataan atau barangkali sedikit berbedanya hal yangkita inginkan terhadap hal yang ada. namun karena hal ini bersifat mutlak maka mau tidak mau perasaan ini akan muncul karena sikapnya tidak sesuai dengan prinsip kita.

adalah hal yang sangat kita ketahui bersama bahwa semua orang yang ada didunia ini adalah tidak sempurna. disatu sisi ada paragdigma hitam dalam hidup kita. disatu sisi ada paradigma putih dan suci dalam hidup ini. semua didunia ini tidak ada yang sempurna. contohnya kalau kita melihat sebuah cahaya putih kita akan senang sekali melihat indahnya warna putih ini karena identik dengan suci dan bersih. kalau kita selidiki lebih dalam ternyata warna putih tersebut terbentuk dari berbagai macam warna yang tergabung manjadi satu sehingga menjadi suatu cahaya putih yang terang bersinar suci dan bersih.

kita melihat suatu lingkarang yang dengan kelengkungannya yang sempurna, sehingga kita takjub akan keindahan sebuah lingkaran tersebut. kalau kita lihat secara detail ternyata lingkaran yang indah itu terbentuk dari jutaan suatu garis tak beraturan yang menyatu hingga terbentuk suatu pola sudut yang kalau kita hitung jumlah sudut dalam lingkaran itu tidak akan bisa kita hitung.

sahabatku semua, kita tentunya selalu ingin mengharapkan suatu kesempurnaan entah itu sepperti lingkaran sempurna tadi atau sebuah cahaya yang berasal dari sinar putih. sudah barang tentu kalau kita mengharapkan kesempurnaan maka kita tidak akan menemukan didunia ini karena hal yang sempurna itu hanyalah milik allah tuhan yang maha kuasa. maka dari pada itu syukurilah apa yang ada didekatmu karena dengan bersyukur insya allah nikmat itu akan ditambah.

bagaimana kita menyikapi ketidaksempurnaan orang yang kita harapkan sempurna, jawabannya tidak akan mungkin, karena balik lagi kepernyataan diatas karena kesempurnaan hanya limik tuhan, lantas bagaimana menyikapinya. simple anda tinggal melihat kesebuah cermin, lihatlah anda dari berbagai perspektif, andapasti juga makhluk dan tentunya tidak sempurna. berarti orang lain yang menginginkan anda juga akan merasa kecewa karena anda tidak sempurna.

ooleh karena itu lihatlah hal yang baik baik saja lihatlah kelebihannya saja dan tutupilah kelemahan dan kekurangan orang yang anda ingin sempurnakan karena insya allah dia akan juga berperilaku hal yang sama dia akan juga menghargai anda dan menerima kekurangan anda. dan bersyukurlah atas nikmat yang diberikan allah. jikalau seseorang yang anda cintai tidak menghargai kelemahan dan ketidaksempurnaan anda, maka bersabarlah dan pamrihlah serta ikhlaslah karena rasa syukur dan cinta datangnya dari allah dan merupakan anugerah allah dan allah akan menunjukkan kebaikan dalam hati dan hidupmu. tawakkaltualallah.

jazakallah.

Ikuti

Get every new post delivered to your Inbox.